Update issues



  • I had a software update for my Neonious One so I plugged in to an ethernet connection and tried updating, but after about 25 minutes the led was still blinking and I couldn't load the IDE. I figured that something might have gone wrong and tried doing a factory reset, which resulted it being stuck trying to reset (or so I think). Currently the NO has been trying to reset for probably an out, with the IDE page stating that it is updating. What can I do to solve this?



  • I apologize for the problem.

    Please try out these instructions: Fixing Updater Issue

    Let me know whether this works for you.

    Thomas



  • I tried using the instructions but with no luck. I am completely unable to connect to the NO using lowsync, I have tried using the NOs own wifi, ethernet connected to my router and ethernet connected directly to my computer but in all cases I get the "The device cannot be reached" message. I also tried to reset the network settings as listed but whenever I restart the NO it goes back to trying to update before 5 seconds, and nothing seems to change.



  • The instructions worked for somebody else with the same problem. I am still very positive to be able fix this.

    All you need to do is be able to connect to the device to change the Wifi settings. So let me help you here.

    Do you actually know the IP of the device in your Ethernet network? Can you ping it? If not, can you give me your 12-digit code, with that I might figure it out for you.

    I will try to answer faster this time when you give me feedback here

    Just FYI (but I do no think you will need this, only if you changed to a Ethernet static IP which is no longer valid):
    Regarding changing the network settings: Why do you think it is trying to go back to update before 5 seconds? Resetting network settings is a stable process even when in update mode, I never seen a problem here. Then, after resetting network settings, it will always continue to try to update till an update is successful. So that is OK. But if you had Ethernet on static, it would now be back on DHCP client mode so you can connect via Ethernet to set the Wifi settings.



  • I know the IP of the device as I have access to the router, which has DHCP enabled, as shown here 52fa70fa-7dec-4daa-b608-7b00a489c78c-image.png
    This is the terminal output I get before trying to reset the network settings f3df61ca-1b8a-4ea5-83c0-5f436e825458-image.png
    and the find my neonious site is unable to find the device (code: 30AEA4604910). This is the terminal output I get after trying to reset the network settings 590779e2-2c20-4146-8150-81c28073ede2-image.png
    I tried holding the button just 5 seconds, but also 8 seconds just to be sure, but with the same results. The Neonious One is relatively new and the only settings that I got to change was setting an IDE password and defaulting to https. The reason why I thought the network reset does nothing is because the red led starts blinking like it is updating immediately when I turn it on no matter what, and the green light never blinks as it should after holding the user button for the network reset.



  • I had it sitting connected to ethernet and power, and after about 4 hours it somehow ended up fixing itself and is now updated. I have since connected it to wifi instead and everything seems to be working fine, so I guess it is solved for now? Thanks for the help anyway.



  • In any case, I am sorry that you had this experience. We are working on making Ethernet more stable.

    And regarding lowsync and accessing settings: You have to switch to HTTP. That was the missing puzzle piece. HTTPS does not work because the certificate is unaccessable in updater mode. Ooops. I will update the doc for future problems!

    Thomas



  • It's no problem, stuff like that happens.
    I did actually try to connect over http with lowsync since after failing it gives you the option to try without https so I figured I should at least try, just forgot to put it in my screenshot, and it have the exact same result as https. So while updating the doc is probably a good idea I don't think http was the missing puzzle piece this time around.



  • Interesting. I guess I will have to try to reproduce this.
    Thank you, and have a nice day!


Log in to reply