npm install mqtt failed and destroyed the demo app as well

  • I first tried to install async-mqtt from IDE. That failed with an unspecific error message. Then I tried to install mqtt, which failed as well. After that, the demo app is not working anymore, it tells me not to be able to resolve the "ws" module. I uninstalled / installled ws successfully, however, I still get the same error. Something feels broken now. How to recover, and is it possible to use the mqtt at all on neonious?

    I tried and failed:

    Now even the demo app is not running anymore:

    Despite of having the module installed (re-installed)

  • This is with the newest version of low.js and the neonious one? I will try this over the weekend and figure out what is going on. I think this should be fixable.

    Till then, you can always factory reset. See , somewhere in the middle.


  • I have Version 20200515 running. I just did the factory reset. Both mqtt and async-mqtt failed to install. Then I tried more factory resets and more packages. camelcase (worked once, failed once), async (failed), underscore (worked twice, failed once), csv-parser (failed), bluebird (failed). Some packages I tried to install multiple times, it appears that they kept failing at different progress-%.

    After fails I got sometimes the message "The connection to your device is not working properly." for a couple of minutes.

    The device is connected to my home LAN via cable.

  • OK I can reproduce the problem.

    It only happens on the neonious one. The external flash does not like a command the new file system LittleFS sends.. I need some more time to find this, but I am pretty sure I know where/how to fix this.


  • Please update to the new version 1.5.1, here it should be fixed:

    Looking forward to hearing how well it works now.!

  • I had the update installed. Since then I cannot access it anymore.

    • The device is not availble via LAN. Previously I did find the device name in my DHCP-lease-list on the router, that is not the case anymore. The previously leased IP-Address is not responding.
    • The red light on the device is constantly blinking
    • ~15 minutes after the update I tried a factory reset, several times. A short moment after the factory reset it goes red-blinking and stays that way
    • There is a LAN-access-point available. However, I will only be able to try accessing it via wlan in the evening.

  • If the red light is blinking, the update is not installed, it is in the updater modus.

    You did a factory reset. So it should show a Wifi? So that is what you mean with LAN-access-point?

    Can you connect to it, then use lowsync to set the Wifi to a Wifi with Internet access? See for the command.
    The IDE is not available in the updater modus.

    Then it should update over Wifi.



  • There was no progress at all.

    So for all day:

    • The NEONIOUS ONE was connected to the internet via LAN-cabel plugged in. I had it unplugged for 3 hours and plugged it in again and its DHCP-IP-lease was renewed. The device had access to the internet for all day.
    • For all day it offered a WIFI-Access-Point that I can connect to
    • Via both networks (home-lan) or directly connected to the access point I get on the Port 8000 the message:
      "low.js device is updating!"

    I tried to connect the device via USB (I guess anything I do via lowsync has to be done via USB). The NEONIOUS ONE did not show up neither under Windows nor under Ubuntu. I made sure to have these kernel mods available under linux ftdi_sio, cp210x and usbserial. On the other hand, when I connected my USB to UART stick, it showed up immediatly as /dev/ttyUSB0.

    The NEONIOUS ONE starts to look a bit bricked 😞

  • It is not bricked, at least not yet. You can change the Wifi settings via lowsync as I wrote in my last message while it says "low.js device is updating". Please do this. Then it can update over Wifi - so I think.

    The updater sometimes shows problems over Ethernet. I have noticed this before with other people (to bad it never shows problems here). The problem is with the custom SPI Flash implementation, that's why we switched to the ESP-IDF 4.0 native SPI Flash implementation in the newest 1.5.1. See:

    It should work then..

    I apologize for the problem.


  • Just a quick add: no, only lowsync works via network. neonious one is a 100% network, 0% USB/UART product.

    The only command which uses USB/UART is lowsync flash, which is not applicable for the neonious one, but for other boards.

  • Got it! Since it was connected to the internet already by cable, I didn't understand why configuring the wifi also to the same LAN would be any good. So I concluded access via USB is needed.

    Got it now, quick steps:

    • lowsync init
    • lowsync settings set wifi.ssid="YOUR_SSID" wifi.password="YOUR_PASS" wifi.mode=station wifi.dhcp=client
      that failed at first, however, once I chose comminication via port 8000 on HTTP things magically resolved themselves

    Installing NPN modules works now just fine.


Log in to reply